Post Reply 
1.09 or 1.09b?
07-16-2009, 07:36 PM
Post: #1
1.09 or 1.09b?
Hello everyone,

Having thoroughly enjoyed Diablo II + LoD, I decided to finaly have some fun playing the original Diablo. Which patch should I apply - the 1.09 or the 1.09b (I'll be running Win XP x86 SP3)? They say 1.09b is for Windows NT. Since Win XP is basically NT based, I guess 1.09b is the one I need. Am I right?
Find all posts by this user
Quote this message in a reply
07-16-2009, 08:55 PM
Post: #2
1.09 or 1.09b?
Hi,

Quote:Which patch should I apply - the 1.09 or the 1.09b (I'll be running Win XP x86 SP3)?
Couldn't remember, so I cranked Diablo up. Both on the splash screen and in game (using 'v') it showed V1.09 -- no 'b'. I'm running XP. I think the NT version was to address some issues with direct hardware control that don't crop up in XP.

--Pete


How big was the aquarium in Noah's ark?

Find all posts by this user
Quote this message in a reply
07-17-2009, 07:40 PM
Post: #3
1.09 or 1.09b?
Thanks, Pete, I guess I'll take the 1.09b.
Find all posts by this user
Quote this message in a reply
07-17-2009, 09:24 PM
Post: #4
1.09 or 1.09b?
Quote:Thanks, Pete, I guess I'll take the 1.09b.

Summary of thread as I see it:

OP: Should I use 109 or 109b? I run XP.
Pete: I use xp and run 109. I believe 109b was for an issue unique to NT.
OP: Thanks, think I will run 109b.

Possible interpretations:
1) The OP has decided not to follow Pete's advice , but appreciates his input.
2) The OP does not understand Pete's advice, but thinks he does, and appreciates his input.
3) I am missing something.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-17-2009, 09:51 PM
Post: #5
1.09 or 1.09b?
It doesn't really matter either way. Both versions work fine with XP.

"What contemptible scoundrel stole the cork from my lunch?"

-W.C. Fields
Visit this user's website Find all posts by this user
Quote this message in a reply
07-18-2009, 07:23 AM
Post: #6
1.09 or 1.09b?
Quote:3) I am missing something.
You are.

I do appreciate the fact that Pete took his time to test both patches (even though he didn't seem to REALLY test them by playing the game). From what I could gather, nobody has found any problems running 1.09b, so, since XP is NT based, I decided to go with 1.09b (even if the issues it fixes do not apply to XP at all, I don't lose anything).
Find all posts by this user
Quote this message in a reply
07-18-2009, 01:24 PM
Post: #7
1.09 or 1.09b?
Quote:It doesn't really matter either way. Both versions work fine with XP.

Ah, but which one activates the secret cow level?
Visit this user's website Find all posts by this user
Quote this message in a reply
07-18-2009, 08:39 PM
Post: #8
1.09 or 1.09b?
Quote:Ah, but which one activates the secret cow level?
That would be 1.09cl

"What contemptible scoundrel stole the cork from my lunch?"

-W.C. Fields
Visit this user's website Find all posts by this user
Quote this message in a reply
09-21-2009, 01:39 PM
Post: #9
1.09 or 1.09b?
Just some little input from me - or better: some little output from Diablo itself. Nothing of importance but maybe nice to know:

Quote:[...] Both on the splash screen and in game (using 'v') it showed V1.09 -- no 'b'. [..]

In addition to pressing v in order to get some version information you can also press shift+v to get some additional version information.
I have tested it on my PC and got these results:

Code:
Diablo Version | Main Menu, v | shift+v
1.00             diablo v1.00   version 96.12.26.3
1.04             ? (patch did not work)
1.07             diablo v1.07   version 98.5.6.1
1.08             diablo v1.08   version 1.08.1
1.09             diablo v1.09   version 1.09.1
1.09b            diablo v1.09   version 1.09.2

Hellfire 1.01 shows 97.5.23.1. I am too lazy to reinstall HF 1.00, sorry.

So here we have different outputs for 1.09 and 1.09b. shift+v seems to display some kind of subversion number. I am wondering what the meaning of the early numbers is. Could be some <year>.<month>.<day>.<sub number> of the patch (internal or public) release date but I have to admit that was before I started playing Diablo and I am just guessing.

--Spelunker
Find all posts by this user
Quote this message in a reply
12-24-2009, 06:45 AM
Post: #10
1.09 or 1.09b?
This one is easy. Log into battlenet, and you will be appropriately updated.
Find all posts by this user
Quote this message in a reply
12-24-2009, 09:47 PM
Post: #11
1.09 or 1.09b?
Quote:This one is easy. Log into battlenet, and you will be appropriately updated.
Will you though? The bnet auto-update feature wasn't working last time I tried it, and hadn't been for a year or two prior to that.

"What contemptible scoundrel stole the cork from my lunch?"

-W.C. Fields
Visit this user's website Find all posts by this user
Quote this message in a reply
12-26-2009, 09:23 PM
Post: #12
1.09 or 1.09b?
Quote:Will you though? The bnet auto-update feature wasn't working last time I tried it, and hadn't been for a year or two prior to that.
Just used it earlier this week with D1, fully updated. Was actually shocked to see battlenet still supported by D1, 95 players. Course I'm having visions of some dusty old Xeon sitting in a corner, and everytime the drive light lights up somebody looks over and goes 'wth, who's still playing Diablo 1'? lol
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: